.
.

Configure link with PPP encapsulation

Configuration link with PPP encapsulation between Rijeka and Zadar routers

IT network with PPP encapsulation

Use the following values to configure PPP encapsulation on the serial link between Rijeka and Zadar:

• 1- Configure the link between Rijeka and Zadar routers with PPP encapsulation.
• 2- Configure CHAP authentication on both routers using the password Cisco.



Rijeka#configure terminal

// Configure the username and password on the Zadar router. The passwords must be the same on both routers. The username must reflect the other routers Hostname exactly
Rijeka(config)#username Zadar password Cisco

// Point-to-point software compression can be configured on serial interfaces that use PPP encapsulation
Rijeka(config)#interface serial 1

// 1- Configure the link between Rijeka and Zadar with PPP encapsulation.
Rijeka(config-if)#encapsulation ppp

// 2- Configure CHAP authentication on both routers using the password Cisco.
Rijeka(config-if)#ppp authentication chap
Rijeka(config-if)#exit


Zadar#configure terminal
Zadar(config)#username Rijeka password cisco
Zadar(config)#interface serial 0
Zadar(config-if)#encapsulation ppp
Zadar(config-if)#ppp authentication chap
Zadar(config-if)#exit


6.1. Rijeka#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.4.0 is directly connected, FastEthernet0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial1


6.2. Zadar#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.15.0 is directly connected, FastEthernet0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial0


6.3. Rijeka#show interfaces serial 1

Serial1 is up, line protocol is up
Hardware is HD64570
Internet address is 192.168.2.1/30
MTU 1500 bytes, BW 1544 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP (here is two NCPs, IPCP and CDPCP)
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of show interface counters never



6.4. Zadar#show interfaces serial 0

Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 192.168.2.2/30
MTU 1500 bytes, BW 1544 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP (here is two NCPs)
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of show interface counters never



6.5. Rijeka#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rijeka
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
username Zadar password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.1.6 255.255.255.252
bandwidth 64
encapsulation frame-relay ietf
frame-relay lmi-type ansi
!
interface Serial1
ip address 192.168.2.1 255.255.255.252
no ip directed-broadcast
clock rate 64000
encapsulation ppp
ppp authentication chap
!
interface FastEthernet0
ip address 172.16.4.1 255.255.255.0
no ip directed-broadcast
bandwidth 100000
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end



6.6. Zadar#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Zadar
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
username Rijeka password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.2.2 255.255.255.252
no ip directed-broadcast
encapsulation ppp
ppp authentication chap
!
interface FastEthernet0
ip address 172.16.15.1 255.255.255.0
no ip directed-broadcast
bandwidth 100000
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end