.
.

Configure Frame Relay between Routers

Configuration Frame Relay between Cisco Routers in IT network

IT network with Frame Relay

Use the following values to configure a Frame Relay connection between 'Bjelovar' and 'Rijeka' routers:

• 1- Use DLCI 101 on Bjelovar and Rijeka to configure a Frame Relay connection.
• 2- Define the Frame Relay encapsulation as IETF on both routers.
• 3- Configure the Frame Relay link to reflect the proper bandwidth of 64kbps.
• 4- Assume Inverse-ARP is disabled and configure both Bjelovar and Rijeka to statically map the remote IP address to the local DLCI.
• 5- Configure the LMI type as ANSI on both 'Bjelovar' and 'Rijeka' routers.



Bjelovar#configure terminal
Bjelovar(config)#interface serial 0

// 2- Define the Frame Relay encapsulation as IETF on both routers
Bjelovar(config-if)#encapsulation frame-relay ietf

// 5- Configure the LMI type as ANSI on both BJELOVAR and Rijeka
Bjelovar(config-if)#frame-relay lmi-type ansi

// 4- Assume Inverse-ARP is disabled and configure both routers BJELOVAR and Rijeka to statically map the
remote IP address to the local DLCI.
// 1- Use DLCI 101 on routers Bjelovar and Rijeka to configure a Frame Relay connection.

Bjelovar(config-if)#frame-relay map ip 192.168.1.6 101 broadcast

// 3- Configure the Frame Relay link to reflect the proper bandwidth of 64kbps.
Bjelovar(config-if)#bandwidth 64

Bjelovar(config-if)#no shutdown
Bjelovar(config-if)#exit
Bjelovar(config)#


Rijeka#configure terminal
Rijeka(config)#interface serial 0
Rijeka(config-if)#encapsulation frame-relay ietf
Rijeka(config-if)#frame-relay lmi-type ansi
Rijeka(config-if)#frame-relay map ip 192.168.1.5 101 broadcast (ietf = ????)
Rijeka(config-if)#bandwidth 64
Rijeka(config-if)#no shutdown
Rijeka(config-if)#exit
Rijeka(config)#


http://www.cisco.com/univercd/cc/td/doc/product/software/ssr921/rpcg/77774.htm

5.1. Bjelovar#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGP…….
Gateway of last resort is not set

10.0.0.0/16 is subnetted, 1 subnets
C 10.10.0.0 is directly connected, FastEthernet0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0


5.2. Rijeka#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGP……..
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.4.0 is directly connected, FastEthernet0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0


5.3. Bjelovar#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Bjelovar
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.1.5 255.255.255.252
bandwidth 64
encapsulation frame-relay ietf
frame-relay lmi-type ansi
frame-relay map ip 192.168.1.6 101 broadcast
!
interface FastEthernet0
ip address 10.10.0.1 255.255.0.0
no ip directed-broadcast
bandwidth 100000
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end


5.4. Rijeka#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rijeka
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.1.6 255.255.255.252
bandwidth 64
encapsulation frame-relay ietf
frame-relay lmi-type ansi
!
interface Serial1
ip address 192.168.2.1 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface FastEthernet0
ip address 172.16.4.1 255.255.255.0
no ip directed-broadcast
bandwidth 100000
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end



5.5. Bjelovar#show frame-relay map

Serial0 (up): ip 192.168.1.6 dlci 101(0x66,0x1860), static,
broadcast, ansi, status defined, active


5.6. Rijeka#show frame-relay map

Serial0 (up): ip 192.168.1.5 dlci 101(0x66,0x1860), dynamic,
broadcast, ansi, status defined, active


5.7. Bjelovar#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)
DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0

input pkts 91 output pkts 24 in bytes 6139
out bytes 10224 dropped pkts 42 in FECN pkts 82
in BECN pkts 50 out FECN pkts 59 out BECN pkts 118
in DE pkts 91 out DE pkts 85
out bcast pkts 71 out bcast bytes 13813
pvc create time 00:32:04, last time pvc status changed 00:32:05


5.8. Rijeka#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)
DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0


5.9. Bjelovar#show frame-relay lmi

show frame-relay lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = ansi
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 160 Num Status msgs Rcvd 137
Num Update Status Rcvd 0 Num Status Timeouts 13


5.10. Rijeka#show frame-relay lmi

show frame-relay lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = ansi
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 160 Num Status msgs Rcvd 137
Num Update Status Rcvd 0 Num Status Timeouts 13


5.11. Bjelovar#show interfaces serial 0

Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 192.168.1.5/30
MTU 1500 bytes, BW 64 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation FRAME-RELAY, loopback not set, keepalive set (10 sec)
LMI enq sent 1472, LMI stat recvd 1472, LMI upd recvd 0, DTE LMI up
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 0 LMI type is ansi frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 300


5.12. Rijeka#show interfaces serial 0

Serial0 is up, line protocol is up
Hardware is HD64570
Internet address is 192.168.1.6/30
MTU 1500 bytes, BW 64 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation FRAME-RELAY, loopback not set, keepalive set (10 sec)
LMI enq sent 1472, LMI stat recvd 1472, LMI upd recvd 0, DTE LMI up
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 0 LMI type is ansi frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 300