.
.

Configure EIGRP routing

Configuration EIGRP routing between 'Rijeka' and 'Zadar' routers
IT network with EIGRP routing

Use the following values to configure the routing between Rijeka and Zadar:
  • 1- Configure EIGRP routing between Rijeka and Zadar routers. Enable EIGRP only on the following networks:
    - 192.168.2.0 255.255.255.252
    - 172.16.4.0 255.255.255.0
    - 172.16.15.0 255.255.255.0
  • 2- Both Rijeka and Zadar should be able to see the Fastethernet network of the neighboring router in its routing table.
  • 3- Configure a default route on Rijeka that forwards the default traffic to BJELOVAR. Redistribute that default route to Zadar using the command redistribute static after configuring EIGRP. router(config-router)#redistribute static

// 1- Configure EIGRP routing between Rijeka and Zadar. Enable EIGRP only on the following networks:
Rijeka#configure terminal
Rijeka(config)#router eigrp 100
Rijeka(config-router)#network 192.168.2.0
Rijeka(config-router)#network 172.16.4.0

// disable auto-summarize
Rijeka(config-router)#no auto-summary

// redistributes traffic from the 'Rijeka' router to 'Bjelovar' router (according ip_nat_inside)
Rijeka(config-router)#redistribute static
Rijeka(config-router)#exit

// 3- Configure a default route on Rijeka that forwards the default traffic to BJELOVAR
// #ip route 0.0.0.0 0.0.0.0 s0 // #ip route 10.10.0.0 255.255.0.0 192.168.1.5 ????????
// Because I worked in the simulator and I've had no problems with "redistribute-static I'm not sure

Rijeka(config)#ip default-network 192.168.1.5 ???????

Zadar#configure terminal
Zadar(config)#router eigrp 100
Zadar(config-router)#network 192.168.2.0
Zadar(config-router)#network 172.16.15.0
Zadar(config-router)#no auto-summary
Zadar(config-router)#end


7.1. Rijeka#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
Gateway of last resort is to network 0.0.0.0

172.16.0.0/24 is subnetted, 2 subnets
C 172.16.4.0 is directly connected, FastEthernet0
D 172.16.15.0 [90/1628160] via 192.168.2.2, 00:00:37, Serial1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0
192.168.2.0/24 is variably subnetted, 2 subnets
C 192.168.2.0/30 is directly connected, Serial1
S* 0.0.0.0 [1/0] via s0


7.2. Zadar#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets
C 172.16.15.0 is directly connected, FastEthernet0
D 172.16.4.0 [90/1628160] via 192.168.2.1, 00:02:10, Serial0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial0
D* 0.0.0.0 [90/1628160] via 192.168.2.1, 00:02:10, Serial0


7.3. Rijeka#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rijeka
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
username Zadar password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.1.6 255.255.255.252
bandwidth 64
encapsulation frame-relay ietf
frame-relay lmi-type ansi
!
interface Serial1
ip address 192.168.2.1 255.255.255.252
no ip directed-broadcast
clock rate 64000
encapsulation ppp
ppp authentication chap
!
interface FastEthernet0
ip address 172.16.4.1 255.255.255.0
no ip directed-broadcast
bandwidth 100000
!
router eigrp 100
redistribute static
network 172.16.0.0
network 192.168.2.0
no auto-summary
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.1.5
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end


7.4. Zadar#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Zadar
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
username Rijeka password cisco
!
ip subnet-zero
!
interface Serial0
ip address 192.168.2.2 255.255.255.252
no ip directed-broadcast
encapsulation ppp
ppp authentication chap
!
interface FastEthernet0
ip address 172.16.15.1 255.255.255.0
no ip directed-broadcast
bandwidth 100000
!
router eigrp 100
network 172.16.0.0
network 192.168.2.0
no auto-summary
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end