.
.

Configure DHCP on the Router

Configuration DHCP on the Router Bjelovar in IT network

IT network router with DHCP

Use the following values to enable DHCP services on the Fastethernet0 LAN of BJELOVAR router:

• 1- Provide devices on this LAN with the IP addresses from the 10.10.0.0 /16 network.
• 2- Exclude the range of IP addresses 10.10.0.1 through 10.10.0.10
• 3- Include the default-gateway address of 10.10.0.1
• 4- Include the DNS server address of 10.10.0.5

// Excluding addresses from pool
Bjelovar#configure terminal

// 2- Exclude the range of IP addresses 10.10.0.1 through 10.10.0.10
// Excluding addresses from pool

Bjelovar(config)#ip dhcp excluded-address 10.10.0.1 10.10.0.10

// specify the DHCP pool name POOLNAME
Bjelovar(config)#ip dhcp pool POOLNAME

// 1- Provide devices on this LAN with the IP addresses from the 10.10.0.0 /16 network
// specifies the subnet network number and mask of the DHCP address pool

Bjelovar(dhcp-config)#network 10.10.0.0 255.255.0.0

// 3- Include the default-gateway address of 10.10.0.1
// Specifies the IP address of the default gateway for DHCP client

Bjelovar(dhcp-config)#default-router 10.10.0.1

// 4- Include the DNS server address of 10.10.0.5
// Specifies the IP address of a DNS server that is available to DHCP client

Bjelovar(dhcp-config)#dns-server 10.10.0.5
Bjelovar(dhcp-config)#exit



8.1. Bjelovar#show running-config

Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Bjelovar
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
ip subnet-zero
!
ip dhcp excluded-address 10.10.0.1 10.10.0.10
!
ip dhcp pool poolname
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1
dns-server 10.10.0.5
!
interface Serial0
ip address 192.168.1.5 255.255.255.252
bandwidth 64
encapsulation frame-relay ietf
frame-relay lmi-type ansi
frame-relay map ip 192.168.1.6 101 broadcast
!
interface FastEthernet0
ip address 10.10.0.1 255.255.0.0
no ip directed-broadcast
bandwidth 100000
!
ip classless
no ip http server
!
line con 0
login
transport input none
password cisco
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end